PiHole - Bloquea publicidad con tu RaspberryPi!

anchoa00

Pues otro más con la pihole funcionando, he metido una nueva SD, instalación limpia de la jessie lite y pa'lante, ahora a ver que más le meto, me estoy planteando quitarle algo de carga al OSMC que tengo en el salón, y pasarle a ésta el transmission, hdd externo y dejarla full time de servidor de descargas, etc.

Muchas gracias por el curro que te has pegado AikonCWD

JuSt1

Otro que comienza a usar PiHole, que maravilla!! no sabía que existía algo así xD mil gracias por el aporte y gran currazo :)

EDITO: no ha sido nada, error técnico xD

JuGuLaToR

#1 Voy saltando de un hilo a otro con problemas xD

Cuando escribo el "curl -L install.pi-hole.net | bash" me tira un Connection timed out y no se instala :(

1 respuesta
AikonCWD

#33 prueba a hacer un ping:

sudo ping -c 5 install.pi-hole.net
sudo ping -c 5 pi-hole.net

A ver que te devuelve. De todas formas pihole está pensado para instalarlo en una rpi de forma "fija", ya que si la apagas por las noches o algo pues no tendrás protección DNS. Y no recomiendo instalar pihole sobre mi imagen d emediacenter pues es muy probable que impacte un poco en su rendimiento.

EDIT:

Haz un:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
reboot

Y luego prueba el comando de install.

1 respuesta
JuGuLaToR

#34 El uso principal va a ser Pi-Hole y cacharrear un poco, realmente la voy a usar poco o nada de media center, al menos de momento.

En cuanto al ping.. lo hace sin problemas, 0% paquetes perdidos y unos 200 y algún milisegundos.

Edito por tu edit. Los comandos esos ya lo puse en su momento siguiendo el tutorial que pusiste en #1 . pero volveré a probar.

1 respuesta
AikonCWD

#35 Haz un:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
reboot

Y luego prueba el comando de install.

1 respuesta
JuGuLaToR

#36 anda ostia, después de hacer el ping, he vuelto a probar el curl -L y ahora ha funcionado a la primera xD

1 1 respuesta
AikonCWD

#37 Perfecto, btw, mis statics de hoy:

2,5k anuncios bloqueados
10% del trafico total eran ads

PiHole totally worth

1 respuesta
JuGuLaToR

#38 Eso donde lo miras?

A mi lo que me jode, es que acabo de descubrir que en mi super modem de ONO no le puedo poner para que "reparta" las DNS de forma automática, así que tendré que ir poniendo la IP de la Rasp en cada aparato a mano.

1 respuesta
AikonCWD

#39 Que modelo de router tienes?

Eso se mira en: http://ip_de_tu_raspberry/admin

Por ejemplo, en mi caso http://192.168.1.111/admin

2 respuestas
JuGuLaToR

#40 Es un Compal CG7486E de ONO, antes lo tenia en modo puente y usaba un router mio para dar ips y wifi, pero empezó dar problemas y lo quité...

anchoa00

Me paso igual que a ti, pero con el de Orange, después de instalarlo me veo que no puedo tocar los DNS en el dhcp del router, al final tan simple como instalar isc-dhcp-server en la raspi y deshabilitar el del router.

1 respuesta
JuGuLaToR

#42 Echaré un ojo a eso, a ver si me las apaño.

anchoa00

Por si te sirve de ayuda:
Instalas:
apt-get install isc-dhcp-server

Habilitas la interfaz que va a "asignar" las direcciones en este fichero:
sudo nano /etc/default/isc-dhcp-server

Buscas esta línea y pones eth0 para el cable o wlan0 para wifi si es tu caso:
INTERFACES="eth0"

Y configuras los rangos y el servidor DNS en:
sudo nano /etc/dhcp/dhcpd.conf

Ejemplo:
Para los DNS, primera ip la raspi y segunda el router (en mi caso)
option domain-name-servers 192.168.1.10, 192.168.1.1;

Aqui defines la red, los rangos de direcciones que va a dar el servidor, puerta de enlace, mascara de red y la de broadcast:

subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.100 192.168.1.110;
option routers 192.168.1.1;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;

Despues hay más opciones que puedes tocar, pero con esto creo que tiras.

1 2 respuestas
JuGuLaToR

#44 Perfecto, ya funciona. Gracias.

Aunque te ha faltado un } al final xD Sin eso no funcionaba.

HeXaN

#40 ¿Puedo tener tu Media Center y esto en la misma Pi?

3 respuestas
JuGuLaToR

#46 Si, pero dice Aikon que igual se resiente mucho el rendimiento con las dos cosas a la vez. Es cuestión de probar.

1 2 respuestas
HeXaN

#47 Miraré de meterlo en una Pi Zero entonces.

1 respuesta
JuGuLaToR

#48 La PiZero no tiene ethernet, no se que tal ira por wifi.

1 respuesta
AikonCWD

#46 #47 Sí, yo he tenido ambas cosas mientras visualizaba pelis H265 y juegos en retropie/moonlight, si miras en htop verás que dnsmasq consume un poco de RAM, pero tampoco es excesivo.

Se puede tener ambas cosas, lo mejor es que lo pruebes y tu mismo veas el rendimiento. Tampoco vas a estar navegando a full con 8000 querys DNS mientras miras 4 pelis, no? xd

1 respuesta
HeXaN

#49 Pillaría un adaptador de USB a Ethernet, claro.

#50 Pues de lujo, ya tengo algo que toquetear xD

1 respuesta
AikonCWD

#51 No hay stock de pizero y el ethernet lo tienes que comprar a parte. Ponlo y prueba, si te funciona mal lo desinstalas con un simple comando:

curl -L uninstall.pi-hole.net | bash
JuGuLaToR

#46 Llevo un rato probando, y reproduce pelis a través de Plex a 1080, se puede ver la Tv con Kodi, jugar al super mario y mas cosas teniendo PiHole activado y no se ralentiza. Lo único que va un poco a trompicones el el puntero del ratón en los menús.

Como dice Aikon, mientras ves pelis o juegas no estás haciendo trabajar a PiHole.

La unica pega es el canal de Formula 1 de movistar, que va como el culo xD Pero he probado en el PC y va igual de mal, así que no es cosa de la Rasp.

#1 Por cierto, las blacklists se actualizan solas o hay que hacer algo?

Y otra cosa, hay un Ad que no me lo bloquea (que haya encontrado), es una especie de pop-up en newpct , no se si es de algún tipo especial que no se puede bloquear por DNS (sale en blanco, pero la ventana está ahí).

1 respuesta
AikonCWD

#53 El ratón en Kodi va como el ojete, pero eso ocurre siempre, incluso en OpenELEC.
Ese canal lo mirás de alguna lista tipo Adryan o Catoal, no? Esos streams son un poco chusteros, no es cosa de la raspberry. Si tienes movistar imagenio contratado puedes instalar un addon para raspberry para ver la iptv pvtr oficialmente en Kodi.

Sobre el tema de blacklist, puedes agregar tu mismo algún dominio deseado (o quitarlo): https://pi-hole.net/faq/how-do-i-whitelist-or-blacklist-a-webiste-or-domain/

/usr/local/bin/blacklist.sh someaddomain.com

Mira el link que te pongo porque te explica como inspeccionar con chrome un ad para meterlo en blacklist correctamente. Sobre el popup... aquí ocurre una cosa. En esa web hay un javascript que abre un popup. PiHole bloquea dominios DNS, por eso el popup se abre "en blanco". Para bloquear el javascript que abre la ventana tendrás que usar algún bloqueador de popups emergentes o similar. No es común que ocurra, pero un sistema basado en DNS como pihole no podrá detectar un javascript de ese tipo :(

Instala ublock como addon y esas minucias las bloquearás a nivel de browser.

2 1 respuesta
JuGuLaToR

#54 El de Formula 1 lo probé por Catoal, no tengo Movistar contratado.

En cuanto al ad, en realidad no me molesta, solo entré a esa web para probar a ver que tal funciona PiHole, ya que suele ser de las más cancerígenas en cuanto a publicidad.

De todos modos le echare un ojo, por si algún día quiero bloquear algo concreto.

acerty

No se como configurar el DHCP del router, me funciona solo si pongo las DNS manualmente, alguna ayudita?:D

Aparte YT me va mal :/ algo he tenido que hacer mal xD.

1 respuesta
JuGuLaToR

#56 Pues depende del router. El DHCP lo dejas activado, y si te da la opción, le pones para que u se de DNS principal la IP de la Raspberry.

Si es como mi router y no te da la opción, pues o pones la DNS manualmente en cada dispositivo, o sigues los pasos que hay en # 44

Ah, y lo de YouTube, me da la impresión de que tardan un poco en arrancar los videos, pero luego van bien. No se si será cosa de PiHole o es que hoy YouTube va así...

2 respuestas
acerty

#57 Si exacto tarda en arrancar el video de YT.

1 respuesta
AikonCWD

#57 #58 A mi me pasa igual, pero tambien le pasa a gente que no tiene pihole... usais firefox? Probad a entrar con google chrome.

1 respuesta
JuGuLaToR

#59 Yo estoy en Chrome. Sin embargo en el movil con la app de YT va perfecto, y usando EDGE tambien. A saber...

1 respuesta

Usuarios habituales

  • JuGuLaToR
  • Bazo
  • Markitos_182
  • AikonCWD
  • R1kz
  • Zurdo8
  • acerty

Tags